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General Safety Summary

General Safety Summary
Review the following safety precautions to avoid injury and prevent damage to this product or any
products connected to it.

To avoid potential hazards, use this product only as specified.

Only qualified personnel should perform service procedures.

While using this product, you may need to access other parts of a larger system. Read the safety sections
of the other component manuals for warnings and cautions related to operating the system.

To Avoid Fire or Personal Injury
Connect and Disconnect Properly. Connect the probe output to the measurement instrument before
connecting the probe to the circuit under test. Connect the probe reference lead to the circuit under test
before connecting the probe input. Disconnect the probe input and the probe reference lead from the circuit
under test before disconnecting the probe from the measurement instrument.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings and markings on the product.
Consult the product manual for further ratings information before making connections to the product.

Do Not Operate Without Covers. Do not operate this product with covers or panels removed.

Do Not Operate With Suspected Failures. If you suspect that there is damage to this product, have it
inspected by qualified service personnel.

Avoid Exposed Circuitry. Do not touch exposed connections and components when power is present.

Terms in this Manual
These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could result in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result in damage to this product
or other property.
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Introduction to the PTD Application Product Description

Product Description
The Protocol Trigger and Decode (PTD) application enables you to decode and simultaneously display
protocol-level information and physical layer signaling.

The PTD application includes the following features:

Simultaneously view signal, characters, and protocol

Decode 8b/10b encoded serial data

Correlate events across physical and link layers

Synchronize your oscilloscope and protocol views

Synchronize user specific pattern with the waveform

Adjust threshold values for bit detection

Related Documentation
Refer to the Optional Applications Software on a Windows-Based Oscilloscope Installation Manual
for the following information.

Software warranty

List of all available applications, compatible oscilloscopes, and relevant software and firmware
version numbers

Applying a new label

Installing an application

Enabling an application

Downloading updates from the Tektronix Web site

NOTE. You can view PDF files of the reference guide and the installation manual from the CD Installation
Browser and from the Documents directory on the Optional Applications Software on a Windows-Based
Oscilloscope CD-ROM.

Application CD Contents
The Optional Applications Software on a Windows-Based Oscilloscope CD-ROM includes files for
the following types of documentation:

Printable file of the RT-Eye Serial Data Compliance and Analysis online help
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Introduction to the PTD Application Access to PDF Files

Printable file of the Protocol Trigger and Decode Tool online help

PDF files of the Methods of Implementation (MOI) for the InfiniBand, PCI Express, and FB-DIMM
serial data standards as they apply to the corresponding compliance modules

Reference guides

Optional Applications Installation manual

Access to PDF Files
You can use any of the following methods to view the various PDF files associated with this application:

Access a file in the Documents directory on the Applications CD from any PC

Select a file from the Start menu in the oscilloscope task bar; you may need to first minimize the
application

Access a file from the Help drop-down list in the PTD application

NOTE. If you do not have an Acrobat reader to view a PDF file, you can get a free copy of the reader from
the www.adobe.com/products/acrobat Web page.

Conventions
Online help topics use the following conventions:

The term “click” is used to indicate choosing an option either with a mouse or by tapping as you
would with a touch screen

The term “Compliance Module” refers to optional “plug-in applications” from Tektronix used for
compliance testing to specific serial data standards

The term “channel” is context dependent. It can refer to the transmit channel of the device under test
or to an oscilloscope channel

The term “DUT” is an abbreviation for Device Under Test

When steps require a sequence of selections using the application interface, the ">" delimiter marks
each transition between a menu and an option. For example, one of the steps to recall a setup file
would appear as File > Recall

2 TDSPTD OnlineHelp
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Introduction to the PTD Application Feedback

Feedback
Tektronix values your feedback on our products. To help us serve you better, please send us suggestions,
ideas, or other comments you may have about your application or oscilloscope.

You can email your feedback to techsupport@tektronix.com, FAX it to (503) 627-5695, or call
1-800-833-9200 (select option 3). Please be as specific as possible and include the following information:

General Information
Oscilloscope model number and hardware options, if any

Probes used

Serial data standard

Signaling rate

Your name, company, mailing address, phone number, FAX number

NOTE. Please indicate if you would like to be contacted by Tektronix regarding your suggestion or
comments.

Application-Specific Information
Software version number

Description of the problem such that technical support can duplicate the problem

If possible, save the oscilloscope waveform file as a .wfm file

If possible, save the oscilloscope and application setup files from the application to obtain both the
oscilloscope .set file and the application .ini file

Once you have gathered this information, you can contact technical support by phone or through
e-mail. If using e-mail, be sure to enter in the subject line "PTD Problem," and attach the .set, .ini,
and .wfm files.

NOTE. To include screen shots, from the oscilloscope menu bar, select File > Export. In the Export dialog
box, enter a file name with a .bmp extension and select Save. The file is saved in the C:\TekScope\Images
directory. You can then attach the file to your e-mail (depending on the capabilities of your e-mail editor).
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Getting Started Protocol Trigger and Decode Control Window

Protocol Trigger and Decode Control Window
The Protocol Trigger and Decode control window consists of three windows, which you can show or
hide from view. Use the Display > Views menu to select which windows to show and which ones to
hide from view.
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Getting Started Protocol Trigger and Decode Control Window

The application window includes:

Controls for selecting data sources and serial standards

Controls for the type of information displayed

Controls for oscilloscope acquisitions

Control for selecting/entering user patterns

Read out threshold values for bit detection

The symbolic window includes:

Character and protocol displays

Controls for configuring information display

Controls for synchronization

Status readout of the decode process

The waveform window includes:

Waveform display

Horizontal zoom controls

TriggerT display control
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Basic Operation File Menu

File Menu
The File menu has the following options:

Menu Selection Function
Save As... Saves the decoded information.
Recall Default Setup Recalls the default settings of the application.
Recall Setup... Recalls the settings from the selected file.
Save Setup... Saves the settings in the selected file.
Minimize Minimizes the application window.
Exit Closes the application.
xxx

Source Menu
The Source menu has the following options:
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Basic Operation Trigger Menu

Menu Selection Function
Instrument Displays a list of data sources: Channels 1–4, Ref 1–4,

and Math 1–4.

Files allows you to browse for waveforms stored in
.wfm format.

File... Opens a waveform file for decoding.
Threshold Opens the Threshold entry dialog box (see page 16) to

enter threshold values.
Invert Waveform Inverts the waveform.
xxx

Trigger Menu
The Trigger menu has the following options:

Menu Selection Function
Setup... Opens the Trigger Setup Control dialog (see page 12).
xxx

Display Menu
The Display menu has the following options:

8 TDSPTD OnlineHelp



Basic Operation Help Menu

Menu Selection Function
Views Displays the following options:

All – Displays the entire application window.

Protocol – Displays the Symbolic window and hides the
waveform window.

Waveform – Displays the Waveform window and hides
the Symbolic window.

None – Displays only Application Controls window.
Word Names Displays Dwords in the Waveform window.
Sample Points Displays Sample points on the waveform.
Recovered Signal Displays the Recovered Signal in the Waveform window.
Original Signal Displays the Original Signal in the Waveform window.
Grid and Levels Displays grids and levels in the waveform.
SATA Decoding Displays the following options:

Primitives – Displays Dwords (four-character
sequences) beginning with a control character in the
Protocol display.

FIS – Displays Frame Information Structure,
disassembly includes frame header information.

ATAPI – Displays AT attachment Packet interface.
Always on Top Keeps the Protocol Trigger and Decode application window

always on top.
xxx

Help Menu
The Help menu has the following options:

Menu Selection Function
Help Topics Displays TDSPTD help file (.chm).
About TDSPTD Displays a dialog box with the version number and the

copyright information of the application.
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Basic Operation Application Controls

xxx

Application Controls

The application window includes controls for selecting data sources and serial standards, the type of
information displayed, and oscilloscope acquisitions and synchronization.

Use the Data Source drop-down list to select your data source. Data sources can be Channels 1-4, Ref 1-4,
or Math 1-4. Selecting File allows you to browse for waveforms stored in .wfm format.

Use the Serial Standard drop-down list to select the serial standard that you want to use in your analysis.
You can select PCI Express, SATA, or a user-defined standard. The standard that you select will also
determine what appears in the Character and Protocol displays.

Enable Sync on Pattern option will allow you to enable/disable synchronization on the pattern.

If you need to synchronise a specific pattern for the waveform, select a serial standard from the drop-down
list, and use Sync Pattern: Enable drop-down box to choose from a list of user patterns populated from
the User Pattern folder (C:\TekApplications\TDSPTD\UserPattern). The files in this folder are
editable and are in the “standard”.csv format, for example, SATA 1.csv.

You can enter a specific sequence of the pattern ranging from 1 character upto 4 characters separated by

commas. For example, K28.5, D10.5, D25.4, D24.4. Click next to the Sync Pattern drop-down list
to enter a user pattern range in the Sync Pattern field, the following dialog box appears. If you enter an
invalid text and click OK, the message “Invalid entry” is displayed.
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Basic Operation Symbolic Area Controls

The Mid Ref and Hysterisis values entered in Threshold entry dialog box (see page 16) is displayed
under Thresholds.

Click Decode Data to analyze the data that is currently selected in the Data source drop-down list.

If you need to acquire data, click Single. This button works similarly to Single button on the front panel of
an oscilloscope. Clicking the Single button in the application starts an acquisition, analyzes the acquired
data, and then updates the display windows. Use the Force Trig button if you need to simulate a trigger
event to complete the acquisition. After the acquisition is complete, the application analyzes the acquired
data and updates the display windows.

Symbolic Area Controls
The symbolic window controls character and word displays as well as configuring information displays.

Click Display > Sata Decoding to select the level of abstraction that you want in the Protocol display.

To synchronize the host oscilloscope with the data that is displayed by the application, use the buttons
under Synchronize Oscilloscope with Character. If you want to see the same area on your oscilloscope that
is displayed in the Waveform window of the PTD application, click Zoom 1. The oscilloscope will zoom
in on the portion of the waveform that you have displayed in the PTD application.

To synchronize the host oscilloscope using cursors, be sure that you have cursors turned on and set to
V-bars on the host instrument. Select a line in either the Character or Protocol display, and click Cursor 1.
The position of Cursor 1 on the oscilloscope will be updated to match the selection in the PTD application.

The Decode Status is a scrolling area that displays information about the decoding process.

The Display > Sata Decoding menu has the following choices:

Primitives-Dwords (four-character sequences) beginning with a control character

FIS-Frame Information Structure, disassembly includes frame header information

ATAPI-AT Attachment Packet Interface

TDSPTD OnlineHelp 11



Basic Operation Waveform Area Controls

NOTE. The Protocol window will be blank if you select FIS or ATAPI with standards other than SATA.
Only SATA contains FIS and ATAPI structures.

Waveform Area Controls
The waveform window displays the waveform and annotations and allows you to zoom a displayed
waveform.

To display the entire waveform without the sample points or the word names, click Show All.

To magnify the waveform horizontally, click In.

To reduce the waveform, click Out. If the waveform is too congested, the sample points and Dwords are
not visible.

Click Dword to set the waveform window to contain four 10b symbols of data.

Click Go To Trig to display the trigger ’T’ position in the waveform view (in the software) corresponding
to the position on the oscilloscope display.

Trigger Setup Controls
Use the Trigger Setup control window to set up direct hardware triggering on 8b/10b characters and words.
This enables you to fill the memory of the instrument with an event of interest rather than taking a random
snapshot. Serial protocol triggering allows you to isolate a variety of link layer control sequences, or faults.
To open this control window, go to the PTD Trigger menu and select Setup.

Use the Trigger On drop-down list to select different serial trigger types: 8b/10b Word, 8b/10b Character,
8b/10b Code Error, or Bit Pattern. Selecting 8b/10b Word allows you to specify a four-character
sequence of 8b/10b-coded characters to trigger on. This can be either from a list of predefined words or
as individual characters. To select predefined primitives, select Word from the Edit group box, and then
use the 8b/10b Word drop-down list to select the word. The standard determines the predefined words
that are available in the list.
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Basic Operation Trigger Setup Controls

To select individual characters, you must choose Character from the Edit group box. The Character
1-4 buttons display the value for the currently selected word. You can change the character values by
clicking a Character button.

Select 8b/10b Character from the Trigger On drop-down list to trigger on only one character. Selecting
Specific Character from the Edit group box allows you to trigger on one specific character. Click
Character to change the character value that you want to trigger on. Selecting Any Valid Control
Character allows you to trigger on the first valid control character found.
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Basic Operation Trigger Setup Controls

By default, the trigger system is loaded with patterns for both positive and negative running disparity.
You can use the Pattern drop-down list to select only characters that arrive after a positive or a negative
running disparity. Note that the Trigger Patterns reflect your selection in the Pattern drop-down list.

To trigger on a code error select 8b/10b Code Error from the Trigger On drop-down-list, and then select
the type of errors that you want to trigger on. You can select one of the error options from the list.

To trigger on a specific bit pattern, select Bit Pattern from the Trigger On drop-down list, and then select
either Binary or Hex from the Format drop-down list. Enter the bit pattern, and then click Apply.
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Basic Operation Character Entry Dialog Box

Character Entry Dialog Box
Use the Character Entry dialog box to modify or change the characters that you want to trigger on. To
access this dialog box, click Character in the Trigger Setup control window.

Select either Character or Hex Data Format. In Character format, click either K or D, and then enter
the decimal values for the character. If you entered a K-character, its symbolic name is shown in the
Value/Name field. If you entered a D-character, its hexadecimal value is shown in the Value/Name field.
You can also click Control Symbol, and the Character field will show the value of that control symbol.

In Hex Data format, enter the Hex Data Byte using the keypad. The corresponding code value is shown in
the Character field. You can also click Control Symbol, and the Character field will show the value of that
control symbol. The Value/Name field displays the 8b/10b character equivalent.
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Basic Operation Threshold Entry Dialog Box

Threshold Entry Dialog Box
Use the Threshold Entry dialog box to modify or change the thresholds for bit detection to potentially
improve performance in low SNR situations.

To enter the threshold values, do the following:

1. Select the type of units for the values you want to enter. If Absolute is selected, the reference levels
will be in Volts. If Percentage is selected, values will be in percentage.

2. Enter the desired mid reference value in Ref Level field. The default value is 50 percent (average
DC of the waveform).

3. Enter the desired hysteresis percent value in the Hysteresis field. The default value is 20 percent.

4. The default Maximum and Minimum voltages for the current waveform is displayed in the Current
Waveform area.

5. Select Reset to Percentage on New Acquisition to set the units to percentage when a new acquisition
occurs.
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How To Synchronize Data

Synchronize Data
When you click any word in the Protocol field, the corresponding character in the Character field is
highlighted and the Waveform displays the beginning of that sequence, starting at the left.

When you click any character in the character field, the Waveform displays the beginning of that sequence,
starting at the left.

Synchronize Data with the Host Instrument
To synchronize a zoom window on the host oscilloscope with the data that is displayed by the PTD
application, do the following:

Click Zoom 1 under Synchronize Oscilloscope with Character. The oscilloscope Zoom 1 display changes
to match the area of the waveform that you have displayed in the PTD application.

To synchronize cursors in the host oscilloscope with the data that is displayed by the PTD application,
do the following:

TDSPTD OnlineHelp 17



How To Define Your Own Standard

1. From the protocol window in PTD, click a character or primitive.

2. From the protocol window in PTD, click Cursor 1 or Cursor 2. The corresponding cursor in the
host oscilloscope moves to the same location.

Define Your Own Standard
To define your own standard, do the following:

1. Open the User file located in C:\TekApplications\TSDPTD\Macros.

2. Use Excel or a similar application to edit the file. The file is in .csv format.

3. Select Save As from the File menu. and type in a unique name in the File name text box.

4. Select .csv format from the Save as type drop-down list.

Your file will appear in the Standard drop-down list in the PTD application.

Show and Hide Windows
To show or hide windows, do the following:

1. Click the Display > Views menu.

2. Select the window(s) that you want to show.

All displays both the Symbolic and Waveform windows

Symbolic displays the Symbolic window but hides the Waveform window

Waveform displays the Waveform window but hides the Symbolic window

None hides both the Symbolic and Waveform windows

Change the Window Size
To change the size of the symbolic window or the waveform window, do the following:

Click the white line that separates the window from other windows. The white line will change color.

Drag the line either up or down.
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